Stop the new Gmail compose from being mandatory

The new compose is a huge step backwards in UI design and features. Based on the feedback in Gmail forums is disliked by nearly every person this interface has been inflicted upon. We who sign this petition, respectfully ask Gmail to scrap the new compose. The UI is too horrific to consider using and is fundamentally flawed. If we wanted to send Tweets we'd use Twitter not Gmail. We use Gmail for EMAIL ! The new compose is not designed for email. It is nothing but a low feature version of Twitter and completely unsuitable for replying to or composing new emails. Thank you

Links


Discussion

No comments yet.

join the discussion

Recent signatures

  • username

    Rudy Fernandes, India

    12 months ago Comments: At the very least, provide the "old" look as an option. Currently, I am using the "basic html" version.
  • username

    Dave Robers, United Kingdom

    1 year ago Comments: Change back to the old one. The new one is rubbish.
  • username

    PENNY RAINES, United States

    1 year ago Comments: MY HUSBAND AND I ARE SENIOR CITIZENS AND DO NOT WANT NOR LIKE ANY CHANGES TO OUR GMAIL PLEASE
See more

Petition highlights

There are no highlights yet.