Leopard Driver for X6570

As a Mac user I am often frustrated at the lack of support for the Mac platform. However I was pleased to see that the X6570 from Lexmark had native Mac drivers. However when I upgraded to Leopard I found that this fabulous printer from Lexmark was broken. Lexmark, PLEASE update your driver to include support for OS X Leopard.

Discussion

No comments yet.

join the discussion

Recent signatures

  • username

    stanUnited States

    5 years ago
  • username

    Bethany CaskeyUnited States

    5 years ago
  • username

    Tom RizzoUnited States

    5 years ago
See more

Petition highlights

There are no highlights yet.